Aktualizacja z poprzednich wersji

Z tego artykułu dowiesz się jak dokonać aktualizacji z poprzednich wersji skryptu do najnowszej.

Proces aktualizacji jest wymagany tylko gdy zmieniamy główną wersję skryptu (główne, publiczne wersje to: 1.0, 2.1, 3.x, 4.0, 4.5 i 4.9). Jeśli zmieniamy tylko podwersję (np. 3.1 na 3.2) to jedyną wymaganą operacją jest podmiana plików na nowe (należy uważać aby nie nadpisać pliku konfiguracyjnego), to samo tyczy się rewizji skryptu (trzecia pozycja w numerze wersji, np. w 4.0.01 jest to numer 01), nie dotyczy to wersji testowych, gdyż między nimi mogą zachodzić niekompatybilne zmiany bez uprzedzenia (chyba, że zaznaczono inaczej).

W skrypt instalacyjny dołączony do tej wersji zawiera wbudowane narzędzie, które umożliwia aktualizację z serii 4.5.x (następuje auto detekcja starego pliku konfiguracyjnego). Starsze wersje nie są obecnie wspierane (a aktualizacja z wersji starszej niż 3.0 nie ma większego sensu - brak Archiwum statystyk). Jest prawdopodobne, że wsparcie dla serii 3.x zostanie przywrócone w dodatkowym skrypcie.

Warunkiem przeprowadzenia skutecznej aktualizacji jest zachowanie starego pliku konfiguracyjnego (config.php) oraz najlepiej całej zawartości katalogu danych (domyślnie data/).

Wyłączenie zbierania danych przed procesem aktualizacji oraz wysłaniem nowych plików na serwer jest bardzo zalecane. Warto także wykonać kopię zapasową danych, tak na wszelki wypadek ;-).

Po ukończeniu aktualizacji należy pamiętać o upewnieniu się czy zbieranie danych jest aktywne oraz o tym aby zmienić kod aktywujący zbieranie danych ze stron. Można wtedy także usunąć stare pliki konfiguracyjne itd.

Uwaga, stare pliki tłumaczeń oraz stare motywy nie są kompatybilne z nową wersją, więc należy je usunąć lub przeportować, tak aby uwzględniały wprowadzone w skrypcie zmiany.

Ostatnia modyfikacja: 2008-02-15 18:54:25 CET

Żaby mogą się wydzierać głośniej niż woły, ale nie pociągną pługa na polu, nie obrócą koła przy prasie i z ich skóry nie zrobisz butów.

Khalil Gibran