Wymagania

Skrypt, jak każda "aplikacja" napisana w PHP, wymaga serwera z obsługą tego języka ;-). W przypadku eStats wymagana wersja to co najmniej 5.2.0.

Szczegółowa lista wymagań, wraz z wymieniem elementów, przez które są wymagane:

  • PHP >= 5.2.0 - cały skrypt;
  • mysql, mysqli, sqlite, ibase, pgsql - przynajmniej jedno z wymienionych rozszerzeń PHP do obsługi baz danych - moduły baz danych;
  • MySQL >= 4.1, SQLite >= 3.3, Firebird >= 2.0 (i kompatybilne), PostgreSQL >= 8.x - dostęp do przynajmniej jednego typu z wymienionych baz danych - moduły baz danych;
  • zlib - opcjonalna - kompresja strony oraz kopii zapasowych przy pobieraniu;
  • bzip - opcjonalna - kompresja kopii zapasowych przy pobieraniu;
  • mbstring - opcjonalna - ulepszona obsługa kodowania UTF-8;
  • gettext - opcjonalna - obsługa tłumaczeń;
  • gd - opcjonalna - generowanie graficznych wykresów, map, itd.;
  • geoip - opcjonalna - zbieranie danych na temat geolokalizacji;

Tylko dwie rzeczy są nieskończone: wszechświat oraz ludzka głupota, ale nie jestem pewien co do tej drugiej.

Albert Einstein